Project

General

Profile

Bug #15698

libGL error when entering 3D display in event viewer (lariatsoft)

Added by Will Foreman over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Event Display
Target version:
-
Start date:
03/01/2017
Due date:
% Done:

0%

Estimated time:
Spent time:
Occurs In:
Experiment:
-
Co-Assignees:
Duration:

Description

Hi,

I am trying to view 3D reconstructed data. When I enter the event viewer, I turn on "Reconstructed" radio button at the bottom, then "Window -> Display 3D" at the top menu. However the program then crashes with this error:

evd [0] libGL error: failed to load driver: swrast
terminate called without an active exception
Aborted

Here is the exact command I am using, sourcing my larsoft build in /lariat/app/users/wforeman/lariat_pbars/localProducts_lariatsoft_develop_e10_prof:

lar -c evd_lariat.fcl -s /lariat/app/users/wforeman/lariat_pbar_20170301T181622_reco2d.root

Relevant UPS active products:
larsoft v06_26_00
lariatsoft v06_26_00
lareventdisplay v06_02_14

Thanks,
Will

History

#1 Updated by Lynn Garren over 3 years ago

  • Status changed from New to Feedback

Googling the error message finds that this is a system problem. Probably related to the hardware driver on the machine you are using. If this is your own machine, you may need to reinstall your hardware driver, or ask the system administrator for help.

#2 Updated by Gianluca Petrillo over 3 years ago

William, can you also update the ticket with information on your configuration? In particular, the platform and operating system are important, and mention if it is a GPVM or any remote node.
As Lynn wrote, this is in deep interplay with the operating system and its drivers.

#3 Updated by Will Foreman over 3 years ago

This occurs on the lariat GPVM, specifically, lariatgpvm03.fnal.gov.

I don't know the platform or OS, sorry.

#4 Updated by Gianluca Petrillo over 3 years ago

That machine is running a 64 bit Scientific Linux Fermi 6.3.
Additional information was given via private communication.

#5 Updated by Gianluca Petrillo over 3 years ago

From Robert Hatcher:

Since I got bit by this recently as well, here's my input:

This happens on SLF5, SLF6.6  SLF6.7 for both ROOT 5 or ROOT 6 when OpenGL is invoked.

The simplest / minimal way to reproduce it is:

$ source /cvmfs/fermilab.opensciencegrid.org/products/larsoft/setup
$ setup root v6_06_08 -q e10:nu:debug
$ root
root [0] TGeoManager::Import("/nashome/r/rhatcher/numi_le_numix.gdml");   
        // load a geometry, any GDML or ROOT file w/ geometry will do
root [1] gGeoManager->GetTopVolume()->Draw("ogl");  
       // attempt to view geometry w/ OpenGL

Info in <TCanvas::MakeDefCanvas>:  created default TCanvas with name c1
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Error in <RootX11ErrorHandler>: GLXBadContext (XID: 6291815, XREQ: 149)

In case it possibly matters:  this is with the X11 display being opened on a Mac OS X 10.11.6 machine running XQuartz 2.7.11 (which works for other X11 stuff but may have some strange interaction with the combination of OpenGL & X11).

Will are you also ssh'ed into the GPVM from a Mac?   
Could someone using a Linux machine see if it works for them.

#6 Updated by Gianluca Petrillo over 3 years ago

From William Foreman:

Yep, I'm ssh'ing from a Mac (10.12.3) using XQuartz 2.7.9 for X11 forwarding.

#7 Updated by Gianluca Petrillo over 3 years ago

For your information, I can not reproduce the problem by running:

source /cvmfs/fermilab.opensciencegrid.org/products/larsoft/setup
setup root v6_06_08 -q e10:nu:debug
root <<EOC
TGeoManager::Import("/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_10_00_rc2/gdml/LArTPCdetector.gdml");
gGeoManager->GetTopVolume()->Draw("ogl");
gApplication->Run();
EOC

on lariatgpvm03.fnal.gov, and X server XQuartz 2.7.11 (xorg-server 1.18.4) running on OSX 10.12.3 (Sierra).
It also works locally with the same commands (thanks to CVMFS).

#8 Updated by Robert Hatcher over 3 years ago

Hmmm. I don't have login privs for that lariat machine, but on dunegpvm01.fnal.gov

[rhatcher@dunegpvm01 ~]$ source /cvmfs/fermilab.opensciencegrid.org/products/larsoft/setup
[rhatcher@dunegpvm01 ~]$ setup root v6_06_08 -q e10:nu:debug
[rhatcher@dunegpvm01 ~]$ root <<EOC
> TGeoManager::Import("/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_10_00_rc2/gdml/LArTPCdetector.gdml");
> gGeoManager->GetTopVolume()->Draw("ogl");
> gApplication->Run();
> EOC
   -------------------------------------------------------------------------
  | Welcome to ROOT 6.06/08                             http://root.cern.ch |
....

Info in <TGeoManager::CloseGeometry>: 9179 nodes/ 990 volume UID's in Geometry imported from GDML
Info in <TGeoManager::CloseGeometry>: ----------------modeler ready----------------
Info in <TCanvas::MakeDefCanvas>:  created default TCanvas with name c1
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Error in <RootX11ErrorHandler>: GLXBadContext (XID: 10486119, XREQ: 149)

Mac OS X El Capitan 10.11.6 + XQuartz 2.7.11 (xorg-server 1.18.4)

So, Gianluca could you try it on dunegpvm01.fnal.gov and perhaps we can narrow down whether it's something about the GPVM or not.

#9 Updated by Gianluca Petrillo over 3 years ago

"Or not."
I obtain a proper window. The greatest disturbance is the complain Error in <TGLViewerBase::RenderOpaque - pre exit check>: GL Error invalid operation, which apparently does not prevent the viewer from working.
It might be useful if you could test it to work on your laptop, using ROOT as distributed by LArSoft (did I mention CVMFS?).

Incidentally, I am using a 3-monitor configuration (laptop + HDMI + external). It's not me boasting (I don't even own any of the three of them!), but I have had X server issues depending on the monitor multiplicity. I have also had a decently long record of trouble with LArSoft event display 3D visualisation in Linux and OSX. I recall it was always at least in part because of the X server end.

#10 Updated by Lynn Garren over 3 years ago

I am able to run this job successfully from both a Linux machine and a laptop running El Capitan. lariatgpvm03 is running SLF6.3. I note that lariatgpvm01 is running SLF6.5. See if this works for you on other lariatgpvm0N machines.

#11 Updated by Robert Hatcher over 3 years ago

I don't know how (and haven't time to track down) using CVMFS on a Mac (I'll accept pointers..)

On Mac OS X El Capitan 10.11.6 + XQuartz 2.7.11 (xorg-server 1.18.4)
I installed ./pullProducts -r /Users/rhatcher/Work/externals d14 nu-v2_11_00 s46-e10 prof

Then:

    export UPS_OVERRIDE=Darwin64bit+14;
    setup_setup;
    setup getopt v1_1_6;
    setup cmake v3_7_1;
    setup gitflow v1_10_2;
    setup nutools v2_11_00 -q e10:prof;
    setup genie_phyopt v2_12_0 -q dkcharmtau;
    setup genie_xsec v2_12_0 -q DefaultPlusMECWithNC;
    setup -j dk2nu v01_04_01h -q e10:prof:r6

(there doesn't seem to be a d15 version of this despite the web pages saying there was ... d14 or d16 only, and even with the UPS_OVERRIDE I had to symlink some art/cet product directories ala, ln -s d14.x86_64.e10.nu.prof d15.x86_64.e10.nu.prof)

With this ROOT + OpenGL works fine.

#12 Updated by Will Foreman over 3 years ago

Sorry for the delay.

I tried this on lariatgpvm01 as suggested by Lynn, but get this error:

%MSG-s ArtException: PostEndJob 20-Jun-2017 13:06:23 CDT ModuleEndJob
cet::exception caught in art
---- OtherArt BEGIN
---- EventProcessorFailure BEGIN
EventProcessor: an exception occurred during current event processing
---- FatalRootError BEGIN
Fatal Root Error: @SUB=RootX11ErrorHandler
GLXBadContext (XID: 6291994, XREQ: 150)
---- FatalRootError END
---- EventProcessorFailure END
---- OtherArt END
%MSG
Art has completed and will exit with status 1.

I'm using lariatsoft v06_40_01. Here's the exact commands I used, after setting up my environment:

lar -c evd_lariat.fcl /pnfs/lariat/persistent/users/wforeman/lariat_pbars/pbar_run2/reco/20885427_8/lariat_r9953_20170609T111956_1_Reco2d.root

Then I click the "Reconstructed" radio button at the bottom, and from the top menu bar I do "Window -> Display3D".

#13 Updated by Lynn Garren about 3 years ago

Is this still a problem? Also, the file you mention is no longer available. If this is still a problem, would you please let us know which lariatsoft release to use and which root file.

#14 Updated by Will Foreman about 3 years ago

Hi Lynn,

Yes, it is still a problem. I'm on lariatgpvm01, after setting up lariatsoft v06_49_00 I do this:

lar -c evd_lariat.fcl /lariat/app/users/wforeman/lariat_test_reco2d.root

After turning on the "Reconstructed" radio button and navigating to "Window -> Display3D" it crashes with this error:

%MSG-s ArtException: PostEndJob 14-Sep-2017 14:36:35 CDT ModuleEndJob
cet::exception caught in art
---- OtherArt BEGIN
---- EventProcessorFailure BEGIN
EventProcessor: an exception occurred during current event processing
---- FatalRootError BEGIN
Fatal Root Error: @SUB=RootX11ErrorHandler
GLXBadContext (XID: 10486298, XREQ: 150)
---- FatalRootError END
---- EventProcessorFailure END
---- OtherArt END
%MSG
Art has completed and will exit with status 1.

#15 Updated by Katherine Lato almost 3 years ago

  • Status changed from Feedback to Rejected

This issue is not reproducible, so we are rejecting it.

#16 Updated by Gianluca Petrillo almost 3 years ago

It may be of some use if when you are on FNAL site you allow us to put our fingers on the machine manifesting the problem.
No guarantee though.

#17 Updated by Katherine Lato over 2 years ago

  • Status changed from Rejected to Closed


Also available in: Atom PDF