Project

General

Profile

Feature #15659

Milestone #15372: art multi-threading phase 1

Feature #15374: Modifying all framework-provided services to be thread safe.

Make FileCatalogMetadata thread safe

Added by Kyle Knoepfel almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
02/24/2017
Due date:
% Done:

100%

Estimated time:
16.00 h
Spent time:
Scope:
Internal
Experiment:
-
SSI Package:
art
Duration:

Description

Must be able to support concurrent writing and reading.

Associated revisions

Revision bbbe72c2 (diff)
Added by Kyle Knoepfel almost 3 years ago

Resolve issue #15659: Make FileCatalogMetadata thread safe

- Required introducing a mutex for suitable locking against concurrent
insertion and reading
- Removed one of the public member functions, which was intended to be
used only during the c'tor
- Concurrent insertion tested

History

#1 Updated by Kyle Knoepfel almost 3 years ago

This service has no ActivityRegistry callbacks.

#2 Updated by Kyle Knoepfel almost 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Resolved with commits art:eac5cd67 and art:bbbe72c2.

#3 Updated by Kyle Knoepfel over 2 years ago

  • Target version set to 1209

#4 Updated by Kyle Knoepfel over 2 years ago

  • Target version changed from 1209 to 2.07.01

#5 Updated by Kyle Knoepfel over 2 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF