Project

General

Profile

Bug #15338

Help with Error in cling::AutoloadingVisitor::InsertIntoAutoloadingState

Added by Marco Del Tutto over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Simulation
Target version:
-
Start date:
01/27/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Experiment:
MicroBooNE
Co-Assignees:
Duration:

out.txt (645 KB) out.txt Build log Marco Del Tutto, 01/27/2017 05:55 AM

Related issues

Is duplicate of LArSoft - Bug #13329: ROOT 6 emits a load of "errors" when running GENIE+Corsika simulationClosed07/22/2016

History

#1 Updated by Marco Del Tutto over 3 years ago

  • File out.txt out.txt added
  • Tracker changed from Feature to Support
  • Category set to Install / build / code mgmt

Hello,

I am trying to build a LArSoft module in uboonecode that makes use of the GENIE re-weighting tools. The build is successful, however many error messages are printed out:

Error in cling::AutoloadingVisitor::InsertIntoAutoloadingState:
   Missing FileEntry for ReWeight/GReWeightI.h
   requested to autoload type genie::rew::GSyst

and many others similar to this.
The attached file contains the output of my "mrb i" command. You can see the error messages towards the end.

I've noticed that Gianluca saw the same problem and opened a bug issue here: https://cdcvs.fnal.gov/redmine/issues/13329. Gianluca saw it happening at runtime and the problem was fixed with a newer version of GENIE. How can I fix it here?

Thanks!
Marco

#2 Updated by Gianluca Petrillo over 3 years ago

  • Related to Bug #13329: ROOT 6 emits a load of "errors" when running GENIE+Corsika simulation added

#3 Updated by Gianluca Petrillo over 3 years ago

Which LArSoft or uboonecode version are you using?

#4 Updated by Marco Del Tutto over 3 years ago

Hi Gianluca, I am using uboonecode v06_21_00.

#5 Updated by Gianluca Petrillo over 3 years ago

  • Status changed from New to Accepted

I can reproduce the problem in exactly the way described in issue #13329.

#6 Updated by Gianluca Petrillo over 3 years ago

  • Related to deleted (Bug #13329: ROOT 6 emits a load of "errors" when running GENIE+Corsika simulation)

#7 Updated by Gianluca Petrillo over 3 years ago

  • Is duplicate of Bug #13329: ROOT 6 emits a load of "errors" when running GENIE+Corsika simulation added

#8 Updated by Gianluca Petrillo over 3 years ago

  • Tracker changed from Support to Bug
  • Category changed from Install / build / code mgmt to Simulation
  • Occurs In v06_21_00 added

I reopened the old issue.

#9 Updated by Lynn Garren over 3 years ago

  • Status changed from Accepted to Feedback

How simply can this problem be reproduced? We will shortly have a new version of genie to test.

#10 Updated by Lynn Garren over 3 years ago

  • Status changed from Feedback to Accepted

We have verified that the problem is resolved in a pre-release of genie v2_12_4. We expect the official release to be announced next week.

#11 Updated by Robert Hatcher over 2 years ago

  • Status changed from Accepted to Assigned
  • Assignee set to Robert Hatcher

assigning this to myself so I can "resolve" and "close" it

#12 Updated by Robert Hatcher over 2 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Marking this resolved as this is now fixed with recent versions of GENIE (at least for v2_12_8, but probably earlier as well).

#13 Updated by Robert Hatcher over 2 years ago

  • Status changed from Resolved to Closed

Marking this closed



Also available in: Atom PDF