Project

General

Profile

Bug #152

SimpleProfiler segmentation fault

Added by Jason Torola over 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Start date:
11/25/2009
Due date:
% Done:

0%

Estimated time:
Spent time:
Duration:

Description

Segmentation fault occurs when profiling specific programs.

Example 1)
Machine - Linux fitz.fasf 2.6.30.9-96.fc11.x86_64 #1 SMP Wed Nov 4 00:02:04 EST 2009 x86_64 x86_64 x86_64 GNU/Linux
Code - segStress.cc
Compiled - g++ rdynamic segStress.cc ( no optimization, Does not segfault with optimization )
Compiler Version - Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
--with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared
--enable-threads=posix --enable-checking=release --with-system-zlib
--enable
__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,objc,obj-c++,java,fortran,ada
--enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre
--enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar
--disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch_32=i586
--build=x86_64-redhat-linux
Thread model: posix
gcc version 4.4.1 20090725 (Red Hat 4.4.1-2) (GCC)

Example 2)
Machine - Linux fitz.fasf 2.6.30.9-96.fc11.x86_64 #1 SMP Wed Nov 4 00:02:04 EST 2009 x86_64 x86_64 x86_64 GNU/Linux
- Linux oink.fnal.gov 2.6.18-128.1.6.el5 #1 SMP Wed Apr 1 06:58:14 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Code - stressFit.cxx ( Located in root/test )
Compiled - g++ -O2 -Wall -fPIC -pthread -m64 -I/home/jrt/bin/root/include -c stressFit.cxx
g++ -O2 -m64 stressFit.o -L/home/jrt/bin/root/lib -lCore -lCint -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -lMathCore -lThread -pthread -lm -ldl -rdynamic -o stressFit

g++ -O2 -m64 stressHepix.o -L/home/jrt/bin/root/lib -lCore -lCint -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -lMathCore -lThread -pthread -lm -ldl -rdynamic  -o stressHepix
Compiler Version - For first machine, Same compiler version as above.
Machine 2 has compiler version
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix
--enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions
--enable-libgcj-multifile --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk
--disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --with-cpu=generic
--host=x86_64-redhat-linux
Thread model: posix
gcc version 4.1.2 20071124 (Red Hat 4.1.2-42)

Please e-mail jason if you need any more information

segStress.cc (1.29 KB) segStress.cc Jason Torola, 11/25/2009 01:42 PM

History

#1 Updated by Ron Rechenmacher over 9 years ago

look at it. saw garbage string printed out and thought that was an indication of scribbling on memory, but upon further analysis, found that the garbage print out would not cause a crash.

#2 Updated by Marc Paterno over 9 years ago

  • Status changed from New to Feedback
  • Priority changed from High to Low

#3 Updated by Marc Paterno over 9 years ago

  • Status changed from Feedback to Remission

#4 Updated by Marc Paterno over 9 years ago

  • Status changed from Remission to Accepted

Running cmsRun on cmssrv140, the profiler sometimes causes segmentation faults. See also bug #219; the runs that do not crash produce inconsistent output.

#5 Updated by Marc Paterno over 9 years ago

We have captured some core files showing crashes, and the crashes occur in libunwind itself.

#6 Updated by Marc Paterno almost 9 years ago

  • Status changed from Accepted to Resolved

It appears this bug is resolved by a combination of patches in libunwind and changes in SimpleProfiler. Because we were never able to make a reproducible test case for this bug, it is difficult to be sure.

#7 Updated by Marc Paterno almost 9 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF