Project

General

Profile

Feature #15128

In the CI regression script add support to fetch input and references files

Added by Vito Di Benedetto over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Spent time:
Experiment:
Stakeholders:
Duration:

Description

Implement --input-files and --reference-files in the CI regression script.
If ifdh fails to fetch the files an exception will be throw that will be treated as warning (The issue is not with the user code, but with the infrastructure).

History

#1 Updated by Michele Fattoruso over 3 years ago

  • Tracker changed from Task to Feature
  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Feature implemented into the feature/michele_fail_fetch branch.

After a discussion, we decided to consider this exception as an error.
A table containing the information about the warnings and the errors have been also added to the report mail, information of what error/warning have been found and a list of required actions, to investigate and/or fix the problem.

#2 Updated by Michele Fattoruso over 3 years ago

  • Target version set to v1_0_0

#3 Updated by Vito Di Benedetto over 3 years ago

  • Status changed from Resolved to Closed

#4 Updated by Vito Di Benedetto over 3 years ago

  • Start date deleted (01/12/2017)

#5 Updated by Vito Di Benedetto over 3 years ago

  • Parent task deleted (#13312)


Also available in: Atom PDF