Project

General

Profile

Bug #14953

Sometime entries are removed from the glidein_config file

Added by Marco Mambelli almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
12/29/2016
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

Troubleshooting [#14952] I noticed that sometimes the entries are lost from the glidein_config file.
This should not happen.
I was unable to identify and reproduce exactly when this happens.
I suspect it is a race condition in add_config_line.
This function is called also by periodic scripts that can run in parallel and is not thread safe.
A race condition may cause a function calling add_config_line to start from an empty glidein_config if a previous call is in progress.
This would erase all previous values.

History

#1 Updated by Marco Mambelli almost 4 years ago

  • Status changed from New to Feedback
  • Assignee changed from Marco Mambelli to Parag Mhashilkar
  • Target version changed from v3_2_x to v3_2_17

Changes are in v3/14953 (branched out of v3/14952 to get the fix)
New function add_config_line_safe added using flock to handle parallel invocations in startd cron.
glidein_startup.sh still uses the old function add_config_line because executions are all serial

#2 Updated by Parag Mhashilkar almost 4 years ago

  • Assignee changed from Parag Mhashilkar to Marco Mambelli

Code changes are ok. But there is inconsistency between flock wait time used v/s wait time mentioned in the comments. Make the appropriate changes and merge it to branch_v3_2.

#3 Updated by Marco Mambelli almost 4 years ago

  • Status changed from Feedback to Resolved

I corrected the comment and merged it

#4 Updated by Parag Mhashilkar almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF