Project

General

Profile

Feature #14786

Rediscuss the content of recob::Track

Added by Gianluca Petrillo almost 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Data products
Target version:
-
Start date:
12/08/2016
Due date:
% Done:

0%

Estimated time:
Experiment:
LArSoft
Co-Assignees:
Duration:

Description

The tracking data product design has been known to be limiting.
An attempt to redefine it was made at the end of 2014, which made a bit of progress but was in the end dropped.

The purpose is to define the proper concepts and content for tracking, and to identify the classes to store that content in and their relations.


Related issues

Is duplicate of LArSoft - Feature #5479: RecoBase objects should have a data member to record how well the algorithm creating the object thinks it didRejected02/19/2014

Blocks LArSoft - Task #14281: Provide an interface for access of reconstructed track informationAccepted10/26/2016

History

#1 Updated by Gianluca Petrillo almost 3 years ago

  • Blocks Task #14281: Provide an interface for access of reconstructed track information added

#2 Updated by Lynn Garren almost 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Erica Snider

#3 Updated by Gianluca Petrillo almost 3 years ago

  • Is duplicate of Feature #5479: RecoBase objects should have a data member to record how well the algorithm creating the object thinks it did added

#4 Updated by Gianluca Petrillo almost 3 years ago

  • Status changed from Assigned to Rejected

recob::Track will be updated per issue #14786.
recob::Hit already has quality information.
For the other data products, if this request is still relevant (and I would think that to be true, for example, for recob::Vertex), they should get a specific request.



Also available in: Atom PDF