Project

General

Profile

Bug #14664

Ambiguous error type when getProductID fails

Added by Kyle Knoepfel about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
I/O
Target version:
Start date:
11/23/2016
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Occurs In:
Scope:
Internal
Experiment:
LArSoft
SSI Package:
art
Duration:

Description

Whenever an attempt to retrieve a ProductID fails via a call to the function getProductID, an art::Exception is thrown with an ambiguous error code InsertFailure.


Related issues

Precedes LArSoft - Necessary Maintenance #15525: Removal of an exception category in art 2.06Closed11/24/201611/24/2016

History

#1 Updated by Christopher Green almost 4 years ago

  • Category set to I/O
  • Status changed from New to Assigned
  • Assignee set to Kyle Knoepfel
  • Target version set to 2.06.00
  • Estimated time set to 4.00 h
  • Experiment LArSoft added
  • Experiment deleted (-)
  • SSI Package art added
  • SSI Package deleted ()

#2 Updated by Kyle Knoepfel almost 4 years ago

  • Subject changed from Erroneous error type when getProductID fails to Ambiguous error type when getProductID fails
  • Description updated (diff)
  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

The original diagnosis of this error was incorrect--the problem is that the InsertFailure error code was being used in two contexts:

  1. Product registration failure, and
  2. Product putting failure.

To solve this problem, we have separated the InsertFailure code into a ProductRegistrationFailure code and a ProductPutFailure code. Whereas product-registration failures will now be signaled by the ProductRegistrationFailure error code, we are willing to retain the InsertFailure code for product-putting failures if the stakeholders deem that migrating to ProductPutFailure would cause unnecessarily burdensome backwards incompatibilities. We will poll the stakeholders for their input, encouraging the migration of InsertFailure to ProductPutFailure.

Resolved with:

#3 Updated by Kyle Knoepfel almost 4 years ago

  • Status changed from Resolved to Closed

#4 Updated by Gianluca Petrillo almost 4 years ago

Also available in: Atom PDF