Project

General

Profile

Bug #14663

HttpServletRequest is null

Added by Phil Adamson almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Category:
Server
Target version:
Start date:
11/23/2016
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Error
Well, this is embarrassing... Unfortunately an unexpected error has occurred.
Please help out your friendly Elog support team and create a Redmine issue with the following details and a description of the action being undertaken when the error occured.

Details

Timestamp: 2016-11-23 16:13:48.260
URI: /Elog/
Query: norLogName=Accelerator+Projects&norLogName=FAST&orUserName=pa&sortingField=Modified+Date
HTTP Status code: 500
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Exception:
An exception occurred processing JSP page /WEB-INF/ElogClient.jsp at line 25
22: 
23: ElogHttpServletRequest elogRequest = new ElogHttpServletRequest(request);
24:
25: clientBean = elogRequest.getClientBean();
26:
27: elogRequest.getSession().setAttribute("clientBean", clientBean);
28:
Stacktrace:

History

#1 Updated by Kyle Hazelwood almost 3 years ago

  • Subject changed from Tried to open the elog form the mcr... to HttpServletRequest is null
  • Category set to Server
  • Status changed from New to Remission
  • Priority changed from Normal to High
  • Target version set to Version 2.0

The elog was restarted to pick up new static files.

On tomcat server stop there is a warning of a idle connection:

2016-11-23 16:17:43.750-0600 SEVERE org.apache.catalina.loader.WebappClassLoader org.apache.catalina.loader.WebappClassLoader.clearReferencesThreads The web application [/Elog] appears to have started a thread named [elog idle connection check] but has failed to stop it. This is very likely to create a memory leak.
2016-11-23 16:17:43.751-0600 SEVERE org.apache.catalina.loader.WebappClassLoader org.apache.catalina.loader.WebappClassLoader.clearReferencesThreads The web application [/Elog] is still processing a request that has yet to finish. This is very likely to create a memory leak. You can control the time allowed for requests to finish by using the unloadDelay attribute of the standard Context implementation.

The error was actually caused by the HttpServletRequest being null. I've never seen the servlet request as null.

2016-11-23 16:23:07.903-0600 SEVERE org.apache.catalina.core.StandardWrapperValve.invoke Servlet.service() for servlet [clientHome] in context with path [/Elog] threw exception [An exception occurred processing JSP page /WEB-INF/ElogClient.jsp at line 23 20: <% 21: ElogConfiguration configuration = (ElogConfiguration) application.getAttribute("configuration"); 22: 23: ElogHttpServletRequest elogRequest = new ElogHttpServletRequest(request); 24: 25: clientBean = elogRequest.getClientBean(); 26: Stacktrace:] with root cause
java.lang.NullPointerException
    at java.util.TreeMap.rotateLeft(TreeMap.java:2060)
    at java.util.TreeMap.fixAfterInsertion(TreeMap.java:2127)
    at java.util.TreeMap.put(TreeMap.java:574)
    at gov.fnal.controls.webapps.Elog.Servlets.ElogHttpServletRequest.<init>(ElogHttpServletRequest.java:54)
    at org.apache.jsp.WEB_002dINF.ElogClient_jsp._jspService(ElogClient_jsp.java:608)

This happened on two consecutive restarts. However, without intervention the elog began working again...

#2 Updated by Kyle Hazelwood almost 3 years ago

This could be a concurrent modification issue. Tree map is not thread safe and I am not currently synchronizing access to the map.

#4 Updated by Kyle Hazelwood over 2 years ago

This happened again today when the elog was restarted! The error stops after a tomcat stop and start and then a few minutes pass.

#5 Updated by Kyle Hazelwood about 1 year ago

  • Status changed from Remission to Resolved

#6 Updated by Kyle Hazelwood about 1 year ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF