Project

General

Profile

Support #14416

Help understanding some error messages

Added by Rob Kutschke almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
User Code
Target version:
-
Start date:
11/04/2016
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

A few weeks ago we ported Mu2e Offline to run with art v2_04_00.

Everything appears to be working correctly but there are some error messages that I just noticed. The occur at the start of a job and have the form:

Error in cling::AutoloadingVisitor::InsertIntoAutoloadingState:
   Missing FileEntry for MCDataProducts/inc/PhysicalVolumeInfo.hh
   requested to autoload type mu2e::PhysicalVolumeInfo

where the class name is the name of a class that is part of a data product. I have not checked very carefully but I believe that every class that is part of a data product seen by the job is present among the error messages.

The full set of error messages is attached as the file log.err

My guess is that we are not correctly building the dict and/or rootmap files and, at runtime, the system does not find a class, issues an error message and then tries a corrective action that succeeds.

log.err (10.6 KB) log.err Rob Kutschke, 11/04/2016 05:00 PM

History

#1 Updated by Kyle Knoepfel almost 4 years ago

  • Tracker changed from Bug to Support
  • Status changed from New to Assigned
  • Assignee set to Christopher Green

We believe this is best solved by sitting down with you and looking at the rootmap files. If there's a time today or tomorrow to do so, that would be preferable.

#2 Updated by Christopher Green almost 4 years ago

  • Category set to User Code
  • Status changed from Assigned to Feedback

Is everything understood and operating for you now?

#3 Updated by Rob Kutschke almost 4 years ago

I can confirm that the problem is understood and that setting ROOT_INCLUDE_PATH correctly fixes the problem.

The problem occurs when:

1) Build the code rooted in directory A
2) Copy the code so that it's root is now in directory B
3) Run the code with pwd other than B

This happens when we build code on Jenkins, install in cvmfs and run the release in cvmfs from my own directory.

Adding the directory B to the tail of ROOT_INCLUDE_PATH fixes the problem.

#4 Updated by Christopher Green almost 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

#5 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF