Project

General

Profile

Bug #14401

Art v2_05_00 failed assertion.

Added by Herbert Greenlee almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Target version:
-
Start date:
11/04/2016
Due date:
% Done:

0%

Estimated time:
Duration:

Description

$ lar -c copy.fcl -s ~greenlee/crash.root
04-Nov-2016 13:31:21 CDT Initiating request to open input file "/nashome/g/greenlee/crash.root"
04-Nov-2016 13:31:23 CDT Opened input file "/nashome/g/greenlee/crash.root"
04-Nov-2016 13:31:28 CDT Opened output file with pattern "%ifb_%tc_merged.root"
MSG-w FastCloning: PostSourceSubRun 04-Nov-2016 13:31:29 CDT PostBeginRun
Fast cloning deactivated for this input file due to ROOT version used to write it (< 6.00/01)
having a different splitting policy.
%MSG
lar: /scratch/workspace/nu-release-build/v2_06_02/s43-e10/debug/build/art/v2_05_00/src/art/Framework/IO/Root/RootOutputFile.cc:219: void {anonymous}::maybeInvalidateRangeSet(art::BranchType, const art::RangeSetx%x
, art::RangeSet&): Assertion `!principalRS.ranges().empty()' failed.
Aborted

Seems to be related to reading older format data.

Here's the complete fcl file:
$ cat copy.fcl
process_name: Copy

source: {
module_type: RootInput
maxEvents: 10 # Number of events to create
}

physics: {

#define the output stream, there could be more than one if using filters 
stream1: [ out1 ]
#end_paths is a keyword and contains the paths that do not modify the art::Event,
#ie analyzers and output streams. these all run simultaneously
end_paths: [ stream1 ]
}

outputs: {
out1: {
module_type: RootOutput
fileName: "merged.root"
compressionLevel: 1
}
}


Related issues

Is duplicate of art - Bug #14430: Art v2_05_00 failed assertion.Closed11/07/2016

History

#1 Updated by Herbert Greenlee almost 3 years ago

  • Status changed from New to Closed

Duplicate of art issue #14430.

#2 Updated by Gianluca Petrillo almost 3 years ago

  • Is duplicate of Bug #14430: Art v2_05_00 failed assertion. added


Also available in: Atom PDF