Project

General

Profile

Feature #14167

Add a feature to update data products used by CI tests

Added by Michele Fattoruso over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Spent time:
Experiment:
Stakeholders:
Duration:

Description

The user should be able, using a dedicated CI phase, to automatically update the reference files used for the comparison during the CI Tests.
This is a NOvA feature request coming from Alex H. at the October Liaison Meeting.

Associated revisions

Revision 7bb47a6d (diff)
Added by Vito Di Benedetto about 4 years ago

implementation of CI phase to update reference files from Michele, issue #14167

Revision 6db272c2 (diff)
Added by Vito Di Benedetto about 4 years ago

implementation of CI phase to update reference files from Michele, issue #14167

History

#2 Updated by Michele Fattoruso over 4 years ago

  • Target version set to v1_0_0
  • Parent task set to #13312

#3 Updated by Michele Fattoruso over 4 years ago

  • % Done changed from 0 to 50

changed the test_runner script to accept the -u option to run the process to update the reference files.
this new function can copy the output file of all the ci tests into the /pnfs directory declared on the ci_test.cgf.
the files are copied to different folders,each test has it's own folder,defined by the STEP_NAME variable into the ci_test.cfg
the idea is to execute the update phase running the tests in a sequential way.using the requires variable to manipulate the order of execution of the different tests.
the tests will use as input,the output of the previously executed tests. (this part should be still configured)
the function now save the output file on the /pnfs directory using the following format: filenameTimestamp.extension
filename is the basename of the file,Timestamp is a variable set into the workflow.cfg file,and it's content is the date in the following format: %Y%m%d%H%M.
the code has been tested locally and need further changes to be completed

#4 Updated by Vito Di Benedetto over 4 years ago

  • Subject changed from Automatically update data product to Add a feature to update data product
  • Description updated (diff)
  • Assignee changed from Michele Fattoruso to Pengfei Ding

#5 Updated by Vito Di Benedetto over 4 years ago

  • Project changed from Continuous Integration (CI) to nova_ci
  • Description updated (diff)
  • Target version deleted (v1_0_0)

#6 Updated by Vito Di Benedetto over 4 years ago

  • Project changed from nova_ci to Continuous Integration (CI)
  • Assignee changed from Pengfei Ding to Michele Fattoruso

#7 Updated by Vito Di Benedetto over 4 years ago

  • Subject changed from Add a feature to update data product to Add a feature to update data products used by CI tests

#8 Updated by Michele Fattoruso over 4 years ago

  • Status changed from New to Work in progress
  • % Done changed from 50 to 80

#9 Updated by Michele Fattoruso over 4 years ago

  • % Done changed from 80 to 90

#10 Updated by Michele Fattoruso over 4 years ago

  • % Done changed from 90 to 100

the feature is implemented into the feature/michele_update_reference branch

The issue is still marked as work in progress because i want to write a brief documentation on how to update your configuration file to enable this new feature

#11 Updated by Vito Di Benedetto about 4 years ago

  • Target version set to v0_7_0

#12 Updated by Vito Di Benedetto about 4 years ago

  • Status changed from Work in progress to Resolved

#13 Updated by Vito Di Benedetto about 4 years ago

  • Status changed from Resolved to Closed

#14 Updated by Vito Di Benedetto about 4 years ago

  • Start date deleted (10/17/2016)

#15 Updated by Vito Di Benedetto about 4 years ago

  • Parent task deleted (#13312)

Also available in: Atom PDF