Project

General

Profile

Bug #13785

server fails misleadingly from -tar_file_name WAS: mixing -f and --tar_file_name problems with RCDS

Added by Dennis Box about 4 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
09/07/2016
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

Just reported by Vito:

Hi Dennis,

I tried the last piece of the permutation of -f and --tar_file_name options.

If I use --tar_file_name before -f the job submission works properly.

i.e. the following command works
jobsub_submit -g --debug -G nova --role=Analysis --expected-lifetime=10m
--memory=100MB --disk=100MB
--resource-provides=usage_model=DEDICATED,OPPRTUNISTIC -M
--email-to= --tar_file_name=dropbox://${HOME}/test.tar.bz2
-f dropbox://${HOME}/project_008929.xml file://${HOME}/test.txt

I wanted to report this other piece, hopefully this can help to track
down the issue.

Thanks,
Vito

On 06/09/16 18:09, Vito Di Benedetto wrote:

Hi Dennys,

it looks like jobsub_submit doesn't like the mix of
-f and --tar_file_name options

The 2 examples below work:

1)
only --tar_file_name option used:

jobsub_submit -g --debug -G nova --role=Analysis --expected-lifetime=10m
--memory=100MB --disk=100MB
--resource-provides=usage_model=DEDICATED,OPPRTUNISTIC -M
--email-to= --tar_file_name=dropbox://${HOME}/test.tar.bz2
file:///grid/fermiapp/common/tools/probe

2)
only -f option used:

jobsub_submit -g --debug -G nova --role=Analysis --expected-lifetime=10m
--memory=100MB --disk=100MB
--resource-provides=usage_model=DEDICATED,OPPRTUNISTIC -M
--email-to= -f dropbox://${HOME}/project_008929.xml
file:///grid/fermiapp/common/tools/probe

While the mix of -f and --tar_file_name options doesn't work:

jobsub_submit -g --debug -G nova --role=Analysis --expected-lifetime=10m
--memory=100MB --disk=100MB
--resource-provides=usage_model=DEDICATED,OPPRTUNISTIC -M
--email-to= -f dropbox://${HOME}/project_008929.xml
--tar_file_name=dropbox://${HOME}/test.tar.bz2
file:///grid/fermiapp/common/tools/probe

- Vito

History

#1 Updated by Dennis Box over 3 years ago

  • Target version changed from v1.2.3 to v1.2.4

#2 Updated by Dennis Box over 3 years ago

  • Target version changed from v1.2.4 to v1.2.5

#3 Updated by Dennis Box almost 3 years ago

  • Target version changed from v1.2.5 to v1.2.7

#4 Updated by Dennis Box almost 3 years ago

In general: do the right thing with -f dropbox:// file:// and /pnfs

These are all related tickets ( and should be merged into one maybe?) #17617 #17828 #16775 #12871 #13785

#5 Updated by Dennis Box over 2 years ago

  • Target version changed from v1.2.7 to v1.2.8

#6 Updated by Dennis Box about 2 years ago

  • Target version changed from v1.2.8 to v1.2.9

#7 Updated by Dennis Box almost 2 years ago

  • Target version changed from v1.2.9 to v1.3.1

#8 Updated by Dennis Box 9 months ago

  • Target version changed from v1.3.1 to v1.3.2
  • Subject changed from mixing -f and --tar_file_name problems to mixing -f and --tar_file_name problems with RCDS

I can reproduce Vitos initial report if --use-cvmfs-dropbox is present.
It is a server side problem so I am moving it to 1.3.2

#9 Updated by Dennis Box 5 months ago

  • Assignee changed from Dennis Box to Shreyas Bhat
  • Status changed from New to Feedback
  • Subject changed from mixing -f and --tar_file_name problems with RCDS to server fails misleadingly from -tar_file_name WAS: mixing -f and --tar_file_name problems with RCDS

This appears to have been fixed as a side effect of adding the --use_cvmfs_dropbox code.

I think the reason I was confused about this earlier is that the server accepts -tar_file_name where the user probably meant --tar_file_name, which the server parses as -t ar_file_name. It fails to submit and gives an unhelpful error message.

I have submitted a fix for this in branch 13785 which I think should go in the release candidate

#10 Updated by Shreyas Bhat 5 months ago

  • Assignee changed from Shreyas Bhat to Dennis Box
  • Status changed from Feedback to Accepted

This looks good. I just wanted to point out that the FERRY-superuser stuff looks like it was merged after this branch was forked, so please be careful merging this back in.

#11 Updated by Dennis Box 5 months ago

  • Status changed from Accepted to Resolved


Also available in: Atom PDF