Project

General

Profile

Bug #13658

prodcosmics_cry_sbnd.fcl error

Added by Kelwin Matias about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Simulation
Target version:
Start date:
08/24/2016
Due date:
% Done:

0%

Estimated time:
1.00 h
First Occurred:
Occurs In:
Duration:

Description

Failed to parse the configuration file 'prodcosmics_cry_sbnd.fcl' with exception
---- Parse error BEGIN
Local lookup error
---- Can't find key BEGIN
sbnd_basic_services (at part "sbnd_basic_services")
---- Can't find key END
at line 48, character 25, of file "/sbnd/app/users/kmatias/larsoft_v05_12_01/localProducts_larsoft_v05_12_01_e9_prof/sbndcode/v05_12_01/fcl/prodcosmics_cry_sbnd.fcl"

@table::sbnd_basic_services   # from simulationservices_sbnd.fcl
^
---- Parse error END

Art has completed and will exit with status 90.

History

#1 Updated by Gianluca Petrillo about 3 years ago

  • Category set to Simulation
  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo
  • Estimated time set to 1.00 h
  • Occurs In v05_12_01 added

I'll take a look this afternoon.

#2 Updated by Gianluca Petrillo about 3 years ago

  • Status changed from Assigned to Feedback

I can't reproduce the problem (a.k.a. "works for me").
The table sbnd_basic_services is defined in services_sbnd.fcl.
Might it be that you have an old version of it on the way?

#3 Updated by Kelwin Matias about 3 years ago

How can I update the services_sbnd.fcl?
I already tried doing:
mrb z
mrbsetenv
mrb install -j8
And that didn't fixed the problem.

Thanks

#4 Updated by Gianluca Petrillo about 3 years ago

I am assuming you are working on a branch based on sbndcode develop branch.
First, you must ensure you have the changes from the GIT server. Check that ${MRB_SOURCE}/sbndcode/sbnscode/LArSoftConfiguration/services_sbnd.fcl contains the expected configuration table (sbnd_basic_services). If not, update the repository:

cd "${MRB_SOURCE}/sbndcode" 
git pull
and, if you are using a feature branch, also:
git merge origin/develop

Then the sequence of commands you have described should work.
If it does not, two possibilities come into my mind:

  • you have a services_sbnd.fcl somewhere else that is taking over the one from the repository (check if any of the files reported by find "$MRB_TOP" -name services_sbnd.fcl might be pulled in instead of the right one)
  • you are configuring sbndcode from the wrong install area (check with ups active | grep sbndcode that the path to sbndcode matches the one you expect, that is the same as $MRB_INSTALL).

#5 Updated by Gianluca Petrillo about 3 years ago

  • Status changed from Feedback to Closed
  • Target version set to v05_12_01

Closing for lack of feedback. Assuming resolved, please reopen if not.



Also available in: Atom PDF