Project

General

Profile

Bug #13530

Conflict messages from UPS setup are less than helpful

Added by Gianluca Petrillo over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
08/12/2016
Due date:
% Done:

100%

Estimated time:
Spent time:
Duration:

Description

When running mrbsetenv I often get conflicting setup errors. For example:

----------- check this block for errors -----------------------
ERROR: Version conflict -- dependency tree requires versions conflicting with current setup of product art: version v2_00_03 vs v2_02_02

I have 18 different repositories checked out, and no idea which is the one which raises the conflict. Of course none of them explicitly depends on art v2_00_03.
The error message should tell what is the highest level setup command that failed. Then, I could easily find the problem with ups depends.


Related issues

Related to ups - Feature #13554: Improved context information upon version conflictClosed08/15/2016

History

#1 Updated by Lynn Garren over 4 years ago

  • Related to Feature #13554: Improved context information upon version conflict added

#2 Updated by Lynn Garren over 4 years ago

  • Status changed from New to Accepted

We will see if we can improve the information reported by mrb. We have also asked for more information from ups itself.

#3 Updated by Lynn Garren over 4 years ago

  • Status changed from Accepted to Resolved
  • Assignee set to Lynn Garren
  • % Done changed from 0 to 100

Please try mrb v1_08_00, now available on woof. mrbsetenv will return a failure at the first problem it encounters and will try to provide helpful hints.

ERROR: Version conflict -- dependency tree requires versions conflicting with current setup of product art: version v2_00_03 vs v2_02_02
ERROR: setup -B artdaq_core v1_05_01 -q +nu:+e10:+s36:+prof failed
ERROR: For more information, type "ups depend artdaq_core v1_05_01 -q +nu:+e10:+s36:+prof" 
                             or "ups list -aK+ artdaq_core v1_05_01" 
ERROR: setup of required products has failed

#4 Updated by Lynn Garren over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF