Project

General

Profile

Bug #13464

Message facility initialisation with "SingleThread" fails

Added by Gianluca Petrillo about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
08/05/2016
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Duration:

Description

While investigating issue #13453, I boiled the problem down to the initialisation of message facility.
This the earth of the problem seems to be a call to:

mf::StartMessageFacility(mf::MessageFacilityService::SingleThread, mf_pset);
which used to work with messagefacility v1_16_26.
Somehow revealing is that if I use mf::MessageFacilityService::MultiThread instead of mf::MessageFacilityService::SingleThread everything seems to work.

I attach an executable that shows the problem. I compiled it with cetbuildtools:

cet_test(testing_test
  SOURCES testing_test.cxx
  LIBRARIES ${MF_MESSAGELOGGER}
            ${MF_UTILITIES}
            ${FHICLCPP}
            ${CETLIB}
)

The error I see is a grim Segmentation fault. Backtrace seems to depend on whether I enable the standard output or the standard error, but this could be a red herring.

testing_test.cxx (521 Bytes) testing_test.cxx Program showing the problem Gianluca Petrillo, 08/05/2016 05:55 PM

Related issues

Blocks LArSoft - Bug #13453: tests using boost unit do not work with art 2.02.01Closed08/04/2016

History

#1 Updated by Gianluca Petrillo about 3 years ago

  • Blocks Bug #13453: tests using boost unit do not work with art 2.02.01 added

#2 Updated by Kyle Knoepfel about 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Kyle Knoepfel
  • % Done changed from 0 to 80
  • Estimated time set to 2.00 h

The problem is understood, and the fix is trivial. The error arose due to cleaning up many ownership semantics of the messagefacility system. Once a test is in place, the fix will be committed.

#3 Updated by Kyle Knoepfel about 3 years ago

Fixed with commit messagefacility:b70d89e.

#4 Updated by Kyle Knoepfel about 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 80 to 100

#5 Updated by Lynn Garren about 3 years ago

LArSoft needs a release with this bug fix in place. But we will test first to confirm that the problem is completely resolved.

#6 Updated by Lynn Garren about 3 years ago

Testing complete. All LArSoft tests now pass. We will proceed with art v2_02_02.

#7 Updated by Kyle Knoepfel about 3 years ago

  • Status changed from Resolved to Closed
  • Target version set to 2.02.02


Also available in: Atom PDF