Project

General

Profile

Feature #13432

Enable the shared memory Transfer plugin to transfer events with 100% reliability

Added by John Freeman about 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
08/03/2016
Due date:
10/01/2016
% Done:

0%

Estimated time:
40.00 h
Experiment:
-
Co-Assignees:
Duration: 60

Description

Currently, there's no guarantee that all events sent from the data logger to the monitoring aggregator get processed by the monitoring aggregator. This is a natural consequence of the fact that the art modules used for monitoring may take longer to process an event than it takes an event to pass through the data logger, and the fact that monitoring by design is unable to exert backpressure on the system. However, with a plan in place to replace the monitoring aggregator with a dispatcher which, rather than running art modules for monitoring purposes, relays events to monitors (Issue #13430), it would be ideal that the dispatcher receive 100% of events which pass through the data logger (we of course will still be unable to guarantee that monitors process 100% of the events, since we have no control over how long it takes other groups' art modules to process events).

History

#1 Updated by Eric Flumerfelt almost 4 years ago

  • Target version set to 576

#2 Updated by Eric Flumerfelt over 3 years ago

  • Status changed from New to Resolved
  • Assignee set to Eric Flumerfelt

The Shmem_transfer plugin has been reimplemented with a circular buffer and optional locking between the reader and writer. This is part of the feature/PluginBasedDataTransfer branch.

#3 Updated by Eric Flumerfelt over 3 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 576 to v2_00_00


Also available in: Atom PDF