Project

General

Profile

Bug #13329

ROOT 6 emits a load of "errors" when running GENIE+Corsika simulation

Added by Gianluca Petrillo over 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Simulation
Target version:
-
Start date:
07/22/2016
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Experiment:
LArSoft
Co-Assignees:
Duration:

Description

When running prodgenie_bnb_nue_cosmic_uboone.fcl with uboonecode v06_00_01, I noticed a long list of errors like:

Error in cling::AutoloadingVisitor::InsertIntoAutoloadingState:
Missing FileEntry for NucleonDecayPrimaryVtxGenerator.h
requested to autoload type genie::NucleonDecayPrimaryVtxGenerator

I did not notice any LArSoft class in the list, but I might be wrong.
I have no evidence of this having any consequence except from decreasing reader attention to (real) errors.

A log is attached.

prodgenie_bnb_nue_cosmic_uboone-20160722-00.log (175 KB) prodgenie_bnb_nue_cosmic_uboone-20160722-00.log Log of `lar -c prodgenie_bnb_nue_cosmic_uboone.fcl -n 10` (wrapped) Gianluca Petrillo, 07/22/2016 04:07 PM

Related issues

Has duplicate LArSoft - Bug #15338: Help with Error in cling::AutoloadingVisitor::InsertIntoAutoloadingStateClosed01/27/2017

History

#1 Updated by Gianluca Petrillo over 3 years ago

  • Occurs In v06_00_01 added

#2 Updated by Brian Rebel over 3 years ago

I have seen a similar behavior, but have not determined if it is a problem or not. I was going to ask Philippe Canal about it, but have not had a chance yet.

#3 Updated by Gianluca Petrillo over 3 years ago

I talked with Philippe Canal and with Chris Green.
My understanding is that ROOT tries to "autoload" some GENIE classes, either because they have no dictionary, or because they have dictionaries but not everything ROOT needs is in there.

It is not clear to me why ROOT is picking those classes specifically, whether they are specified in some map, or if they are discovered in some other manner.
Chris Green also told me that art is trying to minimise autoloading/autoparsing. Apparently these classes went around art somehow.
It would be interesting to understand what triggers the attempt to autoload those headers. I would suspect they are not needed, but in the end it depends on how they are used (e.g., if our code asks ROOT to interpret an expression that involves those classes).

#4 Updated by Kyle Knoepfel over 3 years ago

The build of GENIE needs to be modified to produce .rootmap files whenever the dictionaries are generated. For reference as to how this has been handled in art see:

Please contact for assistance.

#5 Updated by Lynn Garren over 3 years ago

genie uses rootcint, which has been replaced by rootcling, to generate the dictionary.

By request, here is an example of using the rootcling command as invoked when building nutools.

/products/root/v6_06_04b/Linux64bit+2.6-2.12-e10-nu-prof/bin/rootcling 
 -f /home/garren/scratch/local/build/nutools/nutools/EventDisplayBase/EventDisplayBaseCint.cc
 -s /home/garren/scratch/local/build/nutools/lib/libEventDisplayBase.so
 -rml libEventDisplayBase.so
 -rmf /home/garren/scratch/local/build/nutools/lib/libEventDisplayBase.rootmap
 -I/home/garren/devel/nu/nutools
...
 -I/products/root/v6_06_04b/Linux64bit+2.6-2.12-e10-nu-prof/include
 -DUSE_ROOT nutools/EventDisplayBase/ScanWindow.h nutools/EventDisplayBase/Canvas.h nutools/EventDisplayBase/HelpMenu.h nutools/EventDisplayBase/PrintDialog.h nutools/EventDisplayBase/RootEnv.h nutools/EventDisplayBase/ParameterSetEdit.h nutools/EventDisplayBase/ListWindow.h nutools/EventDisplayBase/WindowMenu.h nutools/EventDisplayBase/DisplayWindow.h nutools/EventDisplayBase/ParameterSetEditDialog.h nutools/EventDisplayBase/ServiceTable.h nutools/EventDisplayBase/NavState.h nutools/EventDisplayBase/ObjListCanvas.h nutools/EventDisplayBase/evdb.h nutools/EventDisplayBase/EventHolder.h nutools/EventDisplayBase/View2D.h nutools/EventDisplayBase/FileMenu.h nutools/EventDisplayBase/Printable.h nutools/EventDisplayBase/ColorScale.h nutools/EventDisplayBase/ButtonBar.h nutools/EventDisplayBase/JobMenu.h nutools/EventDisplayBase/View3D.h nutools/EventDisplayBase/EditMenu.h nutools/EventDisplayBase/MenuBar.h LinkDef.h

There is also a cleanup of the generated rootmap

cd /home/garren/devel/nu/nutools/nutools/EventDisplayBase && perl -wapi.bak -e "s&\\.dylib\\.so&.dylib&g; s&^(header\\s+)([^/]+)\$&\${1}nutools/EventDisplayBase/\${2}&" /home/garren/scratch/local/build/nutools/lib/libEventDisplayBase.rootmap

#6 Updated by Lynn Garren over 3 years ago

  • Status changed from New to Resolved

Robert Hatcher has released genie v2_10_10 with improvements to the build of the root dictionary. I confirm that the reported error messages do not appear when genie v2_10_10 is used. genie v2_10_10 will be part of the next nutools and larsoft releases.

#7 Updated by Lynn Garren over 3 years ago

  • Status changed from Resolved to Closed

genie v2_10_10 and dk2nu v01_04_01 are available in the following distributions:

nu-v2_01_03 with art 2.00.03
larsoft-v06_02_02 with art 2.00.03

nu-v2_02_00 with art 2.02.01

#8 Updated by Gianluca Petrillo almost 3 years ago

  • Related to Bug #15338: Help with Error in cling::AutoloadingVisitor::InsertIntoAutoloadingState added

#9 Updated by Gianluca Petrillo almost 3 years ago

  • Status changed from Closed to Assigned
  • Assignee set to Robert Hatcher
  • Occurs In v06_21_00 added
  • Occurs In deleted (v06_00_01)

Regression?
Marco Del Tutto reports in issue #15338 that the warnings are there.
I can confirm that I get the same type of warnings as in the old attached log, in the same old way.

Marco is using uboonecode v06_21_00, which runs GENIE v2_12_2 (genie_xsec v2_12_0).

#10 Updated by Gianluca Petrillo almost 3 years ago

  • Related to deleted (Bug #15338: Help with Error in cling::AutoloadingVisitor::InsertIntoAutoloadingState)

#11 Updated by Gianluca Petrillo almost 3 years ago

  • Has duplicate Bug #15338: Help with Error in cling::AutoloadingVisitor::InsertIntoAutoloadingState added

#12 Updated by Gianluca Petrillo almost 3 years ago

Actually, I can reproduce it also with uboonecode v06_03_00, which I thought should be fixed.

#13 Updated by Gianluca Petrillo almost 3 years ago

Steps to reproduce:

source /products/setup                  # or whatever it takes to have uboonecode UPS
setup uboonecode v06_26_00 -q e10:prof  # or any other v6 release
lar -c prodgenie_bnb_nu_uboone.fcl -n 1

The output should immediately show a sequence of "Error" messages (at this point, the process can be interrupted since the point is already made).

#14 Updated by Lynn Garren almost 3 years ago

We have verified that the problem is resolved in a pre-release of genie v2_12_4. We expect the official release to be announced next week.

#15 Updated by Robert Hatcher about 2 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Marking this resolved as this is now fixed with recent versions of GENIE (verified for v2_12_8, but probably earlier as well).

#16 Updated by Robert Hatcher about 2 years ago

  • Status changed from Resolved to Closed

Marking this closed



Also available in: Atom PDF