Project

General

Profile

Bug #13117

Inline documentation for RemoveIsolatedSpacePoints example does not appear in LArSoft doxygen page

Added by Gianluca Petrillo about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Documentation
Target version:
-
Start date:
07/06/2016
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Experiment:
LArSoft
Co-Assignees:
Duration:

Description

Ditto.

Service examples are there, as is AnalysisExample.
I can't see anything obviously wrong.
Tests for the missing algorithm are documented, but the larexamples/Algorithms directory is completely missing (see http://nusoft.fnal.gov/larsoft/doxsvn/html/dir_5ca5221dee5fb2a9c90a3193722692e2.html).

History

#1 Updated by Gianluca Petrillo about 4 years ago

  • Subject changed from Inline documentation for @RemoveIsolatedSpacePoints@ example does not appear in LArSoft doxygen page to Inline documentation for RemoveIsolatedSpacePoints example does not appear in LArSoft doxygen page

#2 Updated by Lynn Garren about 4 years ago

See update_lar_doxygen.sh and doxylar in laradmin/nightly. laradmin is a redmine git project.

#3 Updated by Lynn Garren about 4 years ago

The log files show a number of issues. I think the problem is not specific to just this one algorithm.

#4 Updated by Gianluca Petrillo about 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo

#5 Updated by Gianluca Petrillo about 4 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

The log Lynn showed me revealed that Doxygen is running on the deployed UPS packages as opposed to the source GIT repositories as I expected.
And it turns out that my examples were not installing a bunch of things.
I have fixed that in develop, and now the examples install a lot of stuff, including something that is not usually installed (CMakeLists.txt, FHiCL files).
The README files have been updated to stress this anomaly, specific to the examples.

#6 Updated by Gianluca Petrillo about 4 years ago

About the copious warnings in the log file: Doxygen is very active in reporting what it think should be different.
It is usually right, but we are not going to systematically fix the whole Doxygen documentation in LArSoft.
For the examples, I did check the warnings on a local run, and fixed the ones I thought should be fixed.
A few of them are left, mostly about undocumented things that are in details namespace and therefore not need a "public" documentation.

#7 Updated by Gianluca Petrillo almost 4 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF