Project

General

Profile

Support #13074

HTTP code 404 should be returned when client requests non-existent log entry

Added by Matthew Strait over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Target version:
-
Start date:
06/30/2016
Due date:
% Done:

0%

Estimated time:
Experiment:
-
Duration:

Description

When the user attempts to view a log entry that doesn't exist, for instance:

http://dbweb5.fnal.gov:8080/ECL/nova/E/show?e=999999

the resulting page should be sent with HTTP code 404 (Not Found). Currently it is sent with code 200 (OK). This allows browsers and scripts to act appropriately without fragile parsing of the page itself.

(Compare with the behavior of requesting a non-existent article from the New York Times, i.e. http://www.nytimes.com/nothinghere)

History

#1 Updated by Margherita Vittone Wiersma over 3 years ago

  • Tracker changed from Bug to Support

Hi Matthew,
this is NOT a bug; this message was actually purposely implemented in the new version to handle this instead of a screen crash dump.
We will see about your request. Thanks
Margherita

#2 Updated by Margherita Vittone Wiersma over 3 years ago

  • Assignee set to Margherita Vittone Wiersma

#3 Updated by Margherita Vittone Wiersma over 3 years ago

Hi Matthew,
I will change the code; i think i replied too quickly thinking you were referring the look of the page.
This might be fixed in next release though.
Thanks

Margherita

#4 Updated by Matthew Strait over 3 years ago

Thanks!

-Matthew

#5 Updated by Margherita Vittone Wiersma over 3 years ago

  • Status changed from New to Resolved

Hi Matthew,
i fixed the code. Please let me know.
Thanks

#6 Updated by Matthew Strait over 3 years ago

It works! Thanks.

-Matthew



Also available in: Atom PDF