Project

General

Profile

Bug #13026

prodsingle_sbnd_withcaldata.fcl fails: Output "out1" must be configured with dataTier ...

Added by Hector Mendez about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Services
Start date:
06/23/2016
Due date:
% Done:

0%

Estimated time:
1.00 h
First Occurred:
Occurs In:
Duration:

Description

Another issue (crash) with the output name file:

lar -c prodsingle_sbnd_withcaldata.fcl -n 2

OptionsHandler caught a cet::exception calling art::FileCatalogOptionsHandler::doProcessOptions()
---- Configuration BEGIN
Output "out1" must be configured with dataTier (--sam-data-tier=out1:<tier>) and streamName (--sam-stream-name=out1:<stream>).
---- Configuration END

Art has completed and will exit with status 90.

Associated revisions

Revision cca4efab (diff)
Added by Gianluca Petrillo about 3 years ago

Removed SAM configuration from standard SBND services

The configuration table "services_sbnd" (and therefore simulation_services_sbnd) don't configure FileCatalogHelper service any more.
A new service_prod_sbnd does.

The idea is that unless you know that you want it, you don't need it.
Production will need it (and a corresponding simulation_services_prod_sbnd will be needed).
If you need it, you'll have to add it to your services configuration.

This shoudl also fix issue #13026 .

History

#1 Updated by Gianluca Petrillo about 3 years ago

  • Subject changed from sbndCode to prodsingle_sbnd_withcaldata.fcl fails: Output "out1" must be configured with dataTier ...
  • Category set to Services
  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo
  • Estimated time set to 1.00 h
  • First Occurred set to v05_12_01
  • Occurs In v05_12_01 added

I can reproduce the problem.

#2 Updated by Gianluca Petrillo about 3 years ago

  • Status changed from Assigned to Resolved

The problem should be fixed in develop branch ( cca4efab31e2233c44667c622fb6b5aeb43a1860 ).

The issue is that the service FileCatalogHelper was configured (by default), and that one requires additional output configuration.
Since this feature drives SAM metadata creation, and we don't need that unless we need that, I have removed that service from the default configuration services_sbnd.
I have also created a services_prod_sbnd configuration table that does include FileCatalogHelper, that will be useful (?) in production.

I have added a unit test that exercises prodsingle_sbnd.fcl and standard_reco_sbnd_basic.fcl (standard_reco_sbnd.fcl still crashes).
Running mrb test will automatically check that at least the very basic does not crash (no physics validation or even output validation whatsoever).

#3 Updated by Gianluca Petrillo about 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF