Project

General

Profile

Bug #12976

standard_reco_sbnd_basic.fcl crashes because of missing art_file_catalog_mc configuration

Added by Hector Mendez about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Reconstruction
Target version:
Start date:
06/21/2016
Due date:
% Done:

100%

Estimated time:
1.00 h
First Occurred:
Occurs In:
Duration:

Description

Crashing when tried to reconstruct the generated output of single particle. Here is
the message:

Failed to parse the configuration file 'standard_reco_sbnd_basic.fcl' with exception
---- Parse error BEGIN
Local lookup error
---- Can't find key BEGIN
art_file_catalog_mc (at part "art_file_catalog_mc")
---- Can't find key END
at line 25, character 25, of file "/lar1nd/app/users/mendez/larsoft_v05_12_01/localProducts_larsoft_v05_12_01_debug_e9/sbndcode/v05_09_01/fcl/standard_reco_sbnd_basic.fcl"

FileCatalogMetadata:  @local::art_file_catalog_mc
^
---- Parse error END

Art has completed and will exit with status 90.

History

#1 Updated by Gianluca Petrillo about 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo
  • Estimated time set to 1.00 h

I can reproduce the problem.

#2 Updated by Gianluca Petrillo about 3 years ago

  • Subject changed from sbndCode to standard_reco_sbnd_basic.fcl crashes because of missing art_file_catalog_mc configuration
  • Category set to Reconstruction
  • Status changed from Assigned to Resolved
  • Target version set to v05_12_01
  • % Done changed from 0 to 100
  • First Occurred set to v05_12_01
  • Occurs In v05_12_01 added

The fix should be in develop branch ( 79b93fdc36848f57fde02257b2ad66a745af0e05 ).

I can now run the job (and standard_reco_sbnd.fcl as well).
Please test and close the issue if the resolution is confirmed.

#3 Updated by Hector Mendez about 3 years ago

after i did: git pull

my make install -j4 failed at:

make2: * No rule to make target `/lar1nd/app/users/mendez/larsoft_v05_12_01/srcs/sbndcode/sbndcode/Utilities/sam_sbnd.fcl', needed by `sbndcode/fcl/sam_sbnd.fcl'. Stop.
make1:
[sbndcode/sbndcode/Utilities/CMakeFiles/+lar1nd+app+users+mendez+larsoft_v05_12_01+build_slf6.x86_64+sbndcode+fcl+sam_sbnd.fcl.dir/all] Error 2
make1: *
* Waiting for unfinished jobs....

#4 Updated by Gianluca Petrillo about 3 years ago

That file has been moved.
You need to redo mrb build -C to make the build system aware that things have been added, removed or, as in this case, moved.
Let us know if the problem persists.

#5 Updated by Gianluca Petrillo about 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF