Project

General

Profile

Bug #12827

Name case conflict in geometry directory

Added by Gianluca Petrillo over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
06/01/2016
Due date:
% Done:

100%

Estimated time:
0.50 h
Duration:

Description

In lar1ndcode/Geo/gdml/LAr1 there are two files with names differing only in capitalization: lar1-enclosureExtras.gdml and LAr1-enclosureExtras.gdml.
This is an accident, as the latter is an evolution of the former, likely produced by the committer using a case-insensitive file system (that is, HFS file system under OSX).
On OSX, just cloning the repository already exposes a conflict between these two files, while under Linux they are considered completely independent and can coexist.


Related issues

Related to LAr1ND code - Bug #12828: Case conflicts in file names should be preventedClosed06/01/2016

Associated revisions

Revision 6ebfd12d (diff)
Added by Gianluca Petrillo over 3 years ago

Removed old LAr1 far detector geometry (issue #12827).

It was creating some GIT weirdness on OSX because of files with names differing only by case.

History

#1 Updated by Gianluca Petrillo over 3 years ago

  • Related to Bug #12828: Case conflicts in file names should be prevented added

#2 Updated by Gianluca Petrillo over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo
  • Estimated time set to 0.50 h

Corey Adams has confirmed that the directory lar1ndcode/Geo/gdml/LAr1 contains the geometry of the LAr1 far detector, and as such is now useless.
I will remove the directory completely. It will always be present in the GIT repository for tags up to v05_09_01 included.

#3 Updated by Gianluca Petrillo over 3 years ago

  • Target version set to v05_12_00
  • % Done changed from 0 to 50

Well, I have broken it even more.
The develop branch has now the LAr1 directory removed (commit 6ebfd12d45608b971acfe52e4d8dbbe4846628d5).
Unfortunately on OSX the fact that master branch still has it seems to produce an even harder break in git flow, that will result in the repository be left in @master@branch.
All fine on Linux.

This will be automatically solved once the changes in develop are merged into master (using a Linux machine).

#4 Updated by Gianluca Petrillo over 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 50 to 100

Fixed in sbncode v05_12_01.

#5 Updated by Gianluca Petrillo over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF