Project

General

Profile

Feature #12630

Previewed entries are stored forever and largely indistinguishable from real entries

Added by Matthew Strait over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Target version:
-
Start date:
05/13/2016
Due date:
% Done:

0%

Estimated time:
Experiment:
NOvA
Duration:

Description

Whenever someone pushes "preview", a new log entry is created and is permanently assigned an entry number distinct from the number of the eventual real entry. The preview entries don't appear on the logbook front page or search results, but are indistinguishable from real entries if one goes directly to them. For instance:

http://dbweb5.fnal.gov:8080/ECL/nova/E/show?e=84935 - 1st preview
http://dbweb5.fnal.gov:8080/ECL/nova/E/show?e=84936 - 2nd preview
http://dbweb5.fnal.gov:8080/ECL/nova/E/show?e=84937 - real entry

There are two problems here:

1) Discontinuous numbers for real entries. The user wonders whether entries were deleted or are somehow hidden.

2) Previewed entries that may well contain incorrect information can be accidentally interpreted as real entries later. The user can arrive at these entries either via a typo'd link or by browsing entries by manually incrementing the entry number.

I imagine that it would be relatively difficult to rewrite how previews are implemented. I propose as a solution to problem #2, at least, that once the user posts the real entry, the content of preview entries are replaced with a string like "[old previewed entry, nothing to see here]".

Thanks,
Matthew

History

#1 Updated by Margherita Vittone Wiersma over 3 years ago

Hi Matthew,
we just saw your redmine post about this issue since our email was not configured properly.
Sorry for the inconvenience.
As you expected, we are not going to change how preview is implemented; however we will prevent showing an entry which is just a preview.
Hope this will be sufficient. Please let us know.

Thank you

Vladimir and Margherita

#2 Updated by Margherita Vittone Wiersma over 3 years ago

  • Assignee set to Margherita Vittone Wiersma

#3 Updated by Matthew Strait over 3 years ago

Yes, that will be helpful. Thanks.

#4 Updated by Margherita Vittone Wiersma over 3 years ago

  • Tracker changed from Bug to Feature
  • Priority changed from Normal to Low

Hi Matthew,
I changed the Tracker to Feature, this is not a Bug, it is the way the code is implemented.
Just a little extra clarification, just as an fyi, on the mechanics of the preview
(as you already guessed):

Entries are created when we do a preview , the preview flag is set to True;
when the entry is posted, preview flag is set to false. Same entry id number is used.

If we preview and discard, NO entry will be kept.

The only time the preview is kept is if the user closes out the window for both
preview and new entry . Entry s kept with preview flag True.

So as I mentioned, I will modify the code where if the user navigates through entries modifying the entry number
a message will be displayed.

Thanks

#5 Updated by Margherita Vittone Wiersma over 3 years ago

  • Status changed from New to Assigned

Hi Matthew,
I fixed the code and it will be available in next release coming soon.
Thanks

Margherita

#6 Updated by Margherita Vittone Wiersma over 3 years ago

  • Status changed from Assigned to Resolved

Resolved in version 7.4 released on June 23rd.



Also available in: Atom PDF