Project

General

Profile

Feature #12577

Make LArSeedService give more complete feedback when a configuration key is missing

Added by Gianluca Petrillo over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Other
Target version:
-
Start date:
05/09/2016
Due date:
% Done:

0%

Estimated time:
2.00 h
Experiment:
LArSoft
Co-Assignees:
Duration:

Description

LArSeedService is deliberately transparent to exceptions from FHiCL reading.
In policies that require a seed for each engine (e.g. preDefinedSeed), if a "engineLabel" configuration key is missing, the reported error will mention only "engineLabel", and there will be no hint that this error is actually coming from LArSeedService.

The service should wrap FHiCL exception and provide additional information about the context where the exception is generated.

History

#1 Updated by Gianluca Petrillo over 4 years ago

  • Category set to Other
  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo
  • Estimated time set to 2.00 h
  • Experiment LArSoft added
  • Experiment deleted (-)

#2 Updated by Gianluca Petrillo over 4 years ago

  • Status changed from Assigned to Closed

I can't reproduce the problem any more. The exception that I collect when a engine instance label is missing (in this case a for module stest02) is:

---- Configuration BEGIN
  LArSeedService: unable to find the parameter value for: 'stest02.a'
---- Configuration END

The exception that I collect when an module label is missing from the configuration is in stead:
---- Configuration BEGIN
  A seed for the instance 'stest01' was requested, but there is no configuration at all for 'stest01' module label.
---- Configuration END

Possibly this was fixed already?
Closing.

Also available in: Atom PDF