Project

General

Profile

Bug #12434

debug-config emits stray comma

Added by Thomas Junk over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
05/02/2016
Due date:
% Done:

100%

Estimated time:
Duration:

Description

If I use

ART_DEBUG_CONFIG=1 lar -c prodgenie_nue_dune10kt_1x2x6.fcl

and pipe the outpout to a text file, strip off the stray lines on top and bottom, and
use the resulting file as a fcl script, I get a parse error due to a stray comma. It also
happens if I use the --debug-config command line argument. I tracked
it down to this line in an input fcl file:

/grid/fermiapp/products/larsoft/lardata/v06_00_00_rc1/job/larproperties.fcl:71 ReflectiveSurfaceDiffuseFractions: [ [ 0.5, 0.5, 0.5 ] ]

and the resulting output of --debug-config is this:

ReflectiveSurfaceDiffuseFractions: [
[
5e-1,
5e-1,
5e-1
],
]

The parse error comes from the last comma. It looks like something's emitting a comma after every
array element, including the last one. There are two other instances of this in the same fcl document, but they look like the same problem.

I see this in art v1_18_05 -f Linux64bit+2.6-2.12 -q debug:e9:nu


Related issues

Is duplicate of fhicl-cpp - Bug #12062: ParameterSet::to_indented_string produces invalid FHiCLClosed03/25/2016

History

#1 Updated by Kyle Knoepfel over 3 years ago

  • Project changed from art to fhicl-cpp
  • Status changed from New to Feedback

This problem was originally reported as issue #12062, and it has been resolved. The question remains if it is necessary to back-port the fix to the art 1.17 branch (currently it is on a ROOT6 branch). MicroBooNE has reported that they do not need such a back-port, but what is 35-ton's position?

#2 Updated by Kyle Knoepfel over 3 years ago

  • Is duplicate of Bug #12062: ParameterSet::to_indented_string produces invalid FHiCL added

#3 Updated by Thomas Junk over 3 years ago

It's not a big deal. I was testing v1_18_05 with ROOT6 and was running into other issues which made me stumble on this one. If no one's complaining about 1.17 I'd say we don't care. But if it can be fixed moving forwards with new versions it would be good.

#4 Updated by Kyle Knoepfel over 3 years ago

Okay, thanks. It will be included for the next ROOT-6 art release (which will be 1.19).

#5 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

#6 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Resolved to Closed

#7 Updated by Kyle Knoepfel over 3 years ago

  • Target version set to 2.00.01


Also available in: Atom PDF