Project

General

Profile

Feature #1237

Get Run object in a service from the preBeginRun stage

Added by Brian Rebel over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Category:
Infrastructure
Target version:
Start date:
04/20/2011
Due date:
% Done:

100%

Estimated time:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

We get our geometry information for our geometry service from the art::Run object. Right now, that means we connect to the postBeginRun signal. However, people would like to create histograms, etc using that information at the start of a job. Clearly beginJob is not able to know about anything stored in an art::Run object, but beginRun would be a logical place to do such tasks. The problem is that the services only know about art::Run objects through the postBeginRun signal...we would really like our service to know about it before doing the beginRun step for the modules.

Associated revisions

Revision 148121bc (diff)
Added by Christopher Green over 8 years ago

Change signature of preBeginRunSignal per issue #1237.

History

#1 Updated by Christopher Green over 8 years ago

  • Category set to Infrastructure
  • Status changed from New to Resolved
  • Assignee set to Christopher Green
  • Target version set to 0.07.00
  • % Done changed from 0 to 100

Implemented with 148121b.

#2 Updated by Christopher Green over 8 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF