Project

General

Profile

Bug #12322

Invalid canonical fcl output

Added by Herbert Greenlee over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/14/2016
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
MicroBooNE
SSI Package:
art
Duration:

Description

Canonical fcl output produced by art --debug-config is sometimes invalid. List-of-list constructs contain an extra , (comma) after last item of outer list.

[ [...], [...], ]
^


Related issues

Is duplicate of fhicl-cpp - Bug #12062: ParameterSet::to_indented_string produces invalid FHiCLClosed03/25/2016

History

#1 Updated by Kyle Knoepfel over 3 years ago

  • Is duplicate of Bug #12062: ParameterSet::to_indented_string produces invalid FHiCL added

#2 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from New to Feedback

This bug was reported earlier in issue #12062. It has been resolved, however can you comment if it is necessary to back-port the bug fix to the art-1.17 series?

#3 Updated by Kyle Knoepfel over 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Resolved
  • SSI Package art added
  • SSI Package deleted ()

Herb reports no need to backport. Closing issue accordingly.

#4 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Resolved to Closed

#5 Updated by Kyle Knoepfel over 3 years ago

  • Target version set to 2.00.01


Also available in: Atom PDF