Project

General

Profile

Bug #12151

NullPointerException when redirecting after adding a comment

Added by Kyle Hazelwood over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Category:
Server
Target version:
Start date:
04/03/2016
Due date:
% Done:

0%

Estimated time:
Duration:

Description

I need to check for the "Referer" header parameter when determining how to redirect the response after a comment/entry are added or edited. Looking at the code it seems obvious, but in three years I haven't seen this error. Is there a browser out there not sending the "Referer" header any longer? Or perhaps are they sending it with the propper spelling of "Referer" after twenty years of http spelling it wrong?

1459621180533_elog_tomcat_log_report.txt (3.26 KB) 1459621180533_elog_tomcat_log_report.txt NullPointerException Kyle Hazelwood, 04/03/2016 08:11 PM

Related issues

Related to Elog - Bug #12030: Slow refreshClosed03/23/2016

History

#1 Updated by Kyle Hazelwood over 3 years ago

  • Category set to Server
  • Status changed from New to Assigned
  • Assignee set to Kyle Hazelwood

This was caused by Beau trying out a new elog shift change comment app. He is not using a browser so the header is not being populated by default. I need to check for this.

#2 Updated by Kyle Hazelwood over 3 years ago

#3 Updated by Kyle Hazelwood almost 3 years ago

  • Status changed from Assigned to Remission
  • Target version set to Version 1.0

#4 Updated by Kyle Hazelwood almost 3 years ago

  • Status changed from Remission to Resolved

I no longer use the refer header for redirect.

#5 Updated by Kyle Hazelwood almost 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF