Project

General

Profile

Feature #11842

Reduce the prominence of the configuration printout when FragmentGeneration creation fails

Added by Kurt Biery over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/29/2016
Due date:
% Done:

0%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

In the DUNE 35-ton DAQ, shifters are often distracted by the error message that says "error creating a CommandableFragmentGenerator with configuration parameters <...>" and miss the error message that provides useful information on the cause of the error (e.g. problem communicating with the hardware).

John proposed that we change the generic message to have "debug" status rather than "error" and change the wording of several messages to help make things more clear.

History

#1 Updated by Kurt Biery over 3 years ago

  • Status changed from New to Resolved

Changes were made in BoardReaderCode to implement this, including a change to the message with the CFG params to make it an Info message.

#2 Updated by Eric Flumerfelt about 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF