Project

General

Profile

Bug #11630

Cannot run event display on DUNE FD MC files

Added by Tingjun Yang over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Category:
Event Display
Target version:
-
Start date:
02/04/2016
Due date:
% Done:

0%

Estimated time:
Spent time:
Occurs In:
Experiment:
DUNE
Co-Assignees:
Duration:

Description

Dear LArSoft experts,

I am having trouble running event display on the DUNE FD MC files.
source /grid/fermiapp/products/dune/setup_dune.sh
setup dunetpc v04_35_00 -q e9:debug
lar -c evd_dunefd.fcl /pnfs/lbne/persistent/dunepro/v04_30_01/reco/prod_gamma_0.1-2.0GeV_isotropic_dune10kt_3mmpitch_workspace/5941989_0/prod_gamma_0.1-2.0GeV_isotropic_dune10kt_3mmpitch_workspace_8_20151202T200952_gen_6ac24003-a076-4740-80b7-660c022cc603_g4_detsim_reco.root

I got the following error:
%MSG
terminate called after throwing an instance of 'cet::coded_exception<art::errors::ErrorCodes, &art::ExceptionDetail::translate>'
what(): ---- Configuration BEGIN
SimpleChannelStatusService does not support dynamic configuration, but it appears that the channel configuration has sensibly changed.
---- Configuration END

Aborted

What does this mean? We may have played with the 35t dead channel map but we do not even have a dead channel map for the DUNE FD.

Thanks,
Tingjun

History

#1 Updated by Gianluca Petrillo over 4 years ago

  • Category set to Event Display
  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo
  • Experiment DUNE added
  • Experiment deleted (-)

I can reproduce the problem.

By the way: congratulations for the bug report. It has taken me less than 2 minutes to reproduce the problem.

#2 Updated by Gianluca Petrillo over 4 years ago

  • Status changed from Assigned to Rejected

The problem is again the geometry configuration.
The support for dynamic change of geometry is quite broken, probably beyond repair.
Input file was generated with dune10kt_v1_3mmpitch_workspace geometry.
The event display configuration is for dune10kt_v1_workspace geometry.

What happens:

  1. LArSoft loads the configured geometry, dune10kt_v1_workspace
  2. LArSoft loads channel status and asks geometry how many channels: 10240
  3. LArSoft loads other services; all rely on the said geometry information when needed
  4. art loads the input file
  5. LArSoft loads a new geometry, dune10kt_v1_3mmpitch_workspace
  6. the channel status updates after the new geometry and asks how many channels: 16072
  7. the channel status service thus realizes that the bad channel list it has can't be valid any more, and it tells you in that strange language that it is not able to "dynamically" load a new channel list

The bug you mention is the expected behaviour, and it supposedly saved you from incompatible configurations.

Note that there is no mechanism to tell depending services that Geometry has changed, and ChannelStatusService is an exception in that it explicitly checks specifically if the geometry has been updated. Expect other services to react even worse.

In general, we don't have any solution to support what you need yet.
Discussion has already taken places, ideas are there, decisions aren't yet.

Solution: use a configuration with the right geometry.

#3 Updated by Tingjun Yang over 4 years ago

Hi Gianluca,

Thank you very much for your investigation and explaining how this happened. I have not tried to run event display on this special geometry and I forgot we need a different configuration for this geometry. I will create a new evd fcl file for this geometry.

Thanks for your time and I will for sure remember this issue now.

Tingjun



Also available in: Atom PDF