Project

General

Profile

Bug #11507

UPS will read temporary files left by common text editors in version and chain directories

Added by Eric Flumerfelt about 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
01/26/2016
Due date:
% Done:

100%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

I've tripped over this several times while making a product "current" manually...I change the version that the files in current.chain (which I copied from a .version folder initially) and discover that when I set up the product, it still sets up the old version. What happens is that UPS will read the files in the directory, and the ~ files left by my text editor get read and matched to the qualifiers before the edited file, and the wrong version gets set up. I've tested and confirmed that this will happen for both the current.chain and .version directories.

History

#1 Updated by Marc Mengel about 4 years ago

  • Status changed from New to Resolved
  • Assignee set to Marc Mengel
  • % Done changed from 0 to 100

...MUST...RESIST...EDITOR...WAR...COMMENTS.... :-)

Since this is a pretty easy fix, I went ahead and just did it in r2868.
Should be in there next time we cut a release.

#2 Updated by Marc Mengel almost 3 years ago

  • Target version set to v5_2_0

#3 Updated by Marc Mengel almost 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF