Project

General

Profile

Feature #10864

Feature #10776: reconcile the lartlite, nudata, and lardatalite data product classes

identify classes in nudata and nutools and LArLite that provide the same functionality with different implementations.

Added by Marc Paterno almost 5 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Target version:
-
Start date:
11/09/2015
Due date:
11/09/2015
% Done:

0%

Estimated time:
8.00 h
Spent time:
Duration: 1

Description

identify classes in nudata and nutools and LArLite that provide the same functionality with different implementations.

[LArLite team]


Related issues

Is duplicate of larliteintegration - Feature #12338: Reconcile the LArLite with the refactored canvas, nusimdata, larsoftobj UPS products and distribution bundlesClosed04/15/2016

History

#1 Updated by Marc Paterno almost 5 years ago

  • Precedes Feature #10865: move data products in nutools into nusimdata added

#2 Updated by Marc Paterno almost 5 years ago

  • Follows Bug #10862: Fix SnapshotImpl.reportPollingSnapshot(). added

#3 Updated by Marc Mengel almost 5 years ago

  • Follows deleted (Bug #10862: Fix SnapshotImpl.reportPollingSnapshot().)

#4 Updated by Patrick Gartung over 4 years ago

  • % Done changed from 0 to 100

#5 Updated by Patrick Gartung over 4 years ago

  • Status changed from Accepted to Assigned
  • Assignee set to Patrick Gartung

#6 Updated by Patrick Gartung over 4 years ago

  • Status changed from Assigned to Accepted
  • Assignee deleted (Patrick Gartung)
  • % Done changed from 100 to 0

#7 Updated by Marc Paterno over 4 years ago

  • Assignee set to Kazuhiro Terao

The remaining work involves determining what nusimdata or larsoftobj classes should be used in LArLite, in place of classes LArLite chooses to deprecate, and modifying LArLite code to use them.

#8 Updated by Marc Paterno over 4 years ago

  • Precedes deleted (Feature #10865: move data products in nutools into nusimdata)

#9 Updated by Marc Paterno over 4 years ago

  • Has duplicate Feature #10849: identify classes in lardatalite and lardata and LArLite that provide the same functionality with different implementations. added

#10 Updated by Marc Paterno over 4 years ago

  • Has duplicate deleted (Feature #10849: identify classes in lardatalite and lardata and LArLite that provide the same functionality with different implementations.)

#11 Updated by Marc Paterno over 4 years ago

  • Is duplicate of Feature #12338: Reconcile the LArLite with the refactored canvas, nusimdata, larsoftobj UPS products and distribution bundles added

#12 Updated by Marc Paterno over 4 years ago

  • Status changed from Accepted to Rejected

This is subsumed by 12388.



Also available in: Atom PDF