Project

General

Profile

Bug #10844

Inconsistent dependencies in uboonecode

Added by Gianluca Petrillo almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/06/2015
Due date:
% Done:

0%

Estimated time:
Duration:

Description

The commit 3caf3638de43e3a648cad731178be5ebc27d182c changes uboonecode/uboone/CMakeLists.txt in a way that makes uboonedaq_datatypes required, but ups/product_deps still lists it as optional.

Can this inconsistency be fixed?
My personal preference is to have it still optional if possible.

For reference: the old pattern was to have uboonedaq_datatypes optional, and uboone/CMakeLists.txt file would exclude those Beam* directories from compilation when uboonedaq_datatypes was not available.


Related issues

Related to uBooNE code - Bug #10141: uboonedaq_datatypes dependency of uboonecode is not optional any moreClosed2015-09-14

History

#1 Updated by Gianluca Petrillo almost 4 years ago

  • Related to Bug #10141: uboonedaq_datatypes dependency of uboonecode is not optional any more added

#2 Updated by Gianluca Petrillo almost 4 years ago

  • Status changed from New to Rejected

Ops... I just realized that the issue is "fixed" in develop, by making uboonedaq_types mandatory.



Also available in: Atom PDF