Project

General

Profile

Bug #1057

Specifying maximum output file size does not work

Added by Brian Rebel over 8 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
I/O
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
art
Duration:

Description

When trying to run a job that converts raw ArgoNeuT data to ROOT format I attempted to use the RootOuput maxFileSize parameter to limit the output to be <= 1GB. The job produced a file of size 1.6 GB. Chris looked into the reason for that and found that the hook for checking the output file size and triggering the re-open was disabled unintentionally during the conversion from fw.

It would be helpful to have this facility in place in the future releases. If it is easy to fix, v0.5.3 would be nice, but the release after is also acceptable.


Related issues

Is duplicate of art - Milestone #896: Design and specify maxEvents for output streamsClosed02/01/201101/01/2014

History

#1 Updated by Walter E Brown almost 8 years ago

  • Status changed from New to Accepted

#2 Updated by Christopher Green about 6 years ago

  • Category set to I/O
  • Status changed from Accepted to Rejected
  • Start date deleted (03/08/2011)
  • Scope set to Internal
  • Experiment - added
  • SSI Package art added


Also available in: Atom PDF