Project

General

Profile

Bug #10538

Event display cannot read data products with an instance name

Added by Tingjun Yang almost 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Event Display
Target version:
-
Start date:
10/14/2015
Due date:
10/23/2015
% Done:

100%

Estimated time:
2.00 h
Spent time:
Occurs In:
Experiment:
-
Co-Assignees:
Duration: 10

Description

I am trying to use larsoft event display to read some 35t raw data that have both a module label and an instance name. The event display does not work if the product has an instance name (i.e. one cannot specify the label as "label:instance" in the configuration box.).

History

#1 Updated by Gianluca Petrillo almost 4 years ago

  • Due date set to 10/23/2015
  • Category set to Event Display
  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo
  • Estimated time set to 2.00 h

Preliminary analysis show the problem is relatively easy to solve.
Need to check details.

#2 Updated by Gianluca Petrillo almost 4 years ago

After some mistakes and wrong checks, it turns out the event display can read data products with an instance name.
In the dialogue window Edit > Configure Drawing > RawDrawingOptions, the product label needs to be specified as "ProductLabel:InstanceName" (note the double quotes). Isn't that great?

No, it's not, because the double quotes are stripped by the event display machinery and the next time the window is accessed one has to retype them again.
This is very much beyond LArSoft.

I have published a branch feature/Issue10538 in lareventdisplay that does not solve anything but is still better code.

#3 Updated by Gianluca Petrillo almost 4 years ago

Follow up in nutools issue #10659 .

#4 Updated by Gianluca Petrillo almost 4 years ago

  • Status changed from Assigned to Feedback

While there is no actual solution to the underline problem, probably lying in nutools, a workaround has been provided that the users seem to be happy with.

Waiting for confirmation of the latter statement from the submitters (added in the watch list) before marking as resolved.

#5 Updated by Tingjun Yang almost 4 years ago

I confirm using quotation mark and colon I am able to plot raw digits in the event display. Thank you so much for your investigation and recipe.

#6 Updated by Gianluca Petrillo almost 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Marking as resolved.
It would be good if the glitch from nutools could be resolved, too.

#7 Updated by Katherine Lato almost 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF