Project

General

Profile

Bug #10486

LArSoft event display does not show waveform for DUNE35t

Added by Gianluca Petrillo almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Event Display
Target version:
-
Start date:
10/12/2015
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:
Occurs In:
Experiment:
-
Co-Assignees:
Duration:

Description

Starting with LArSoft v04_26_00, the raw waveform plot in the 2D event display is always empty.
This was reported by Tingjun Yang

History

#1 Updated by Gianluca Petrillo almost 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo

#2 Updated by Gianluca Petrillo almost 5 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h

The problem is in fact due to a typo where instead of the value of channel status (an integer), the code was checking the value of the channel ID (another integer).

Solution is trivial; pushed in lareventdisplay develop branch as commit:e5a5484e6b3197a3c4632eb1cff2bc6e55f896c7 .

#3 Updated by Tingjun Yang almost 5 years ago

I confirm Gianluca's change fixed the problem. Thank you.

#4 Updated by Lynn Garren almost 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF