Project

General

Profile

Necessary Maintenance #10358

artapp_basicOptions_print_t should be less strict

Added by Christopher Green almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
09/30/2015
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Scope:
Internal
Experiment:
-
SSI Package:
art
Duration:

Description

The above-mentioned test currently compares its output against a reference. This test can fail if unexpected modules are present in LD_LIBRARY_PATH such as, for instance, when the art suite is part of an MRB working area.

The test should be reconfigured to test for the presence of expected fragments of output rather than comparing against a rigid reference.


Related issues

Related to cet-is - Bug #10407: LibraryManager::getSpecsByPath should not throw whenever a long spec is not availableClosed2015-10-06

Has duplicate cet-is - Bug #10357: fix fragile testsRejected2015-09-30

Associated revisions

History

#1 Updated by Christopher Green almost 4 years ago

  • Is duplicate of Bug #10357: fix fragile tests added

#2 Updated by Christopher Green almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Kyle Knoepfel
  • Estimated time set to 2.00 h

#3 Updated by Christopher Green almost 4 years ago

  • Status changed from Assigned to Rejected

Rejected as duplicate.

#4 Updated by Kyle Knoepfel almost 4 years ago

  • Status changed from Rejected to Assigned

One of these should not be rejected.

#5 Updated by Christopher Green almost 4 years ago

  • Is duplicate of deleted (Bug #10357: fix fragile tests)

#6 Updated by Christopher Green almost 4 years ago

  • Has duplicate Bug #10357: fix fragile tests added

#7 Updated by Lynn Garren almost 4 years ago

This bug makes it impossible to build artextensions in the same build as the art suite, as the tests are guaranteed to fail. This bug is one piece that needs to be fixed for the stated goal of building larsoft against a new release of art after art is tagged and before the official art release build begins.

#8 Updated by Kyle Knoepfel almost 4 years ago

  • Related to Bug #10407: LibraryManager::getSpecsByPath should not throw whenever a long spec is not available added

#9 Updated by Kyle Knoepfel almost 4 years ago

Although this issue proper has been resolved, it points to another bug--specifically that if experiments do not adopt the library-naming convention as in art, then an exception will be thrown whenever LibraryManager::getSpecsByPath is called on a path that does not follow that convention. I have therefore created a new issue (#10407) to remove the exception throwing from that function.

Implemented with art:4c08288.

#10 Updated by Kyle Knoepfel almost 4 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

#11 Updated by Christopher Green almost 4 years ago

  • Target version set to 1.17.00

#12 Updated by Kyle Knoepfel over 3 years ago

  • Target version changed from 1.17.00 to 2.01.00

Due to unforeseen consequences, this issue was not solved for 1.17.00, but will be retargeted for art:version:"Arcturus". A more robust fix was included in art:commit:21d1665.

#13 Updated by Kyle Knoepfel over 3 years ago

  • Target version changed from 2.01.00 to 1.17.05

#14 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF