Project

General

Profile

Bug #1018

Newly-revived maker2_t test fails

Added by Christopher Green over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Category:
Navigation
Target version:
Start date:
02/25/2011
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

The newly-revived test in test/Framework/Core fails, I think because of the way we have changed the construction of workers in Art vs the CMS framework. I had one stab at fixing things but seem to have missed the mark.

The error is:

[greenc@oink] ~/work/cet-is/art-build $ ctest -I 7,7, -V
<snip>
- ---- LogicError BEGIN
Problem using an incomplete BranchDescription
Module label is not allowed to be empty
Please report this error to the FWCore developers
---- LogicError END
<snip>

I think the problem is in the following three lines:

  ModuleDescription m;
  std::auto_ptr<Worker> w1 = ModuleFactory::makeWorker(params1,m);
  std::auto_ptr<Worker> w2 = ModuleFactory::makeWorker(params2,m);

Does anyone know the (almost certainly) quick fix for this?

Associated revisions

Revision abf82983 (diff)
Added by Christopher Green over 9 years ago

With Marc: fix for issue #1018.

History

#1 Updated by Christopher Green over 9 years ago

  • Status changed from New to Resolved
  • Assignee set to Christopher Green
  • % Done changed from 0 to 100

Resolved with commit abf8298.

#2 Updated by Marc Paterno over 9 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF