Project

General

Profile

Recent LArIATSoft Version Change? [RESOLVED]

Added by Ryan Linehan almost 6 years ago

Hi all,

I have been working with LArSoft/LArIATSoft for the past few weeks, up until a few days ago when I dropped it to study for finals. I tried to re-access it today and ended up getting some version inconsistency error when I tried to set up the environment (develop_lariat command):

-------------------Updating git------------------
From ssh://cdcvs.fnal.gov/cvs/projects/lariatsoft * branch develop -> FETCH_HEAD
error: Ref refs/remotes/origin/develop is at 221067f9b7e9ea48d889f460a34977158efc05a1 but expected 62e3b07e7a03123a46c9d7946d231064f5d2188a
! 62e3b07..221067f develop -> origin/develop (unable to update local ref)

(Then, below this a few lines, is: )

ERROR: Version conflict -- dependency tree requires versions conflicting with current setup of product lariatonline: version v01_00_03 vs v01_01_04

I haven't touched anything since it was working a few days ago, so I'm guessing that maybe it had something to do with the reboot that happened yesterday? Maybe? Maybe not? If it wasn't that, is there a general way of dealing with these version conflict errors?

Thanks!

///////////////// SOLUTION //////////////////////

go to your $MRB_BUILDDIR

perform a clean build:
mrb z
mrbsetenv
mrb i -j8

This should fix the problem.

//////////////////////////////////////////////////